Spark AR: Target Tracker Issue

Trackers
Assets and Objects
Target Tracker Issues

Please, review the documentation to make sure that you’re following the right process:

- World Effects with Target Tracking

https://sparkar.facebook.com/ar-studio/learn/tutorials/target-ar-effect#getting-started

- Best Practices for Target Tracking in Spark AR Studio

Before you choose a target image for your target tracking effect, it’s a good idea to check these best practices. Not all images make good targets. Choosing a bad target image could mean your effect doesn’t respond to it.

https://sparkar.facebook.com/ar-studio/learn/articles/world-effects/best-practice-for-target-tracking

If you’ve followed these steps, and you’re still experiencing issues with target tracker, please reply to this thread with the following:

- Device model
- Effect ID
- IG version
- Target image
- Result

Thanks,
Asked about 2 months ago by
Spark AR Team
3 Votes4 FollowersSeen by 4
  • Featured Answer
    • Roberto 331 answers
      Hi all,

      “We have launched an investigation on this issue and here is our finding.


      - Both target trackers (pre v114 and post v114) take initialization motion to track the target in a stable manner. However, the new improved target tracker from v114+ will immediately render the content when the target is detected before initialization.

      I will let you know about any new update
      • View previous comments
      • I have conducted many tests yesterday and the problem is still here.
        Even by just adding a 3D model to the target tracking template, you can clearly see the bug... shown in the videos I posted previously.
        When can we expect this issue to be fixed? We are working for a major French brand, so we absolutely need the effect to be reliable.
        See More
        Posted about a week ago by Patrick
      • Hi Patrick, I apologise for the delay. Its not an easy task, because it is actually working for many creators. The team is looking at your examples, and I will come back to you shortly.
        Posted about a week ago by Roberto
      • Hello Roberto,
        I understand that some creators may not need positioning to be precise and are thus not noticing our problem.
        I have tried creating a very basic ...effect with just an image and an elongated cube and this is what happens: https://youtu.be/kUlajJc3do8
        I have tried creating the project on several computers, with different target images and testing the effect on several mobile devices in a good lighting condition, and it always happens to me (it does not always happen on start, but the problem will occur for sure at some point).
        See More
        Posted on Tuesday by Patrick
      • Hi Patrick,

        The team is looking into a longer term solution. For now, please follow:
        ...
        - Try UTT-movable if it’s a large AR effect for an immediate resolution
        - For this video, the target first was tracked properly by Pattern Tracker, then after user moves around for a while, the UTT static was initialized, but it seems the anchored pose was wrong.
        - Possible reason can be: target placed horizontally (SLAM can be confused during the transition of camera down and forward), white background could confuse the SLAM.

        Let me know if that helps, while we continue investigating.
        See More
        Posted on Thursday by Roberto