Clear
Back

Changelog

To find out what's new in Spark AR Studio, check our release notes below. New versions are released every 2 weeks.

We often launch new features and make some big changes, so make sure to read these notes before upgrading.

Version v76 - Nov 25, 2019

New

  • Quickly build an effect using a template. The pre-designed projects can be customized by importing your own objects and assets or adjusting inputs in the Inspector. Access them by opening Spark AR Studio or selecting File > New From Template.
  • Streamline effect creation with actions, a feature that packages common, repetitive steps into shortcuts. For example, it can take up to 10 steps to place an object on a face effect, but with actions, this process can be reduced to a single click.
  • Allow people to to gradually control something in an Instagram effect by adding a native slider to it. For example, users can make an object in an effect bigger or smaller by adjusting the slider.
  • Publish target tracking effects — effects that are triggered by specific objects or textures found in the world — to Instagram.
  • Upload effects directly from Spark AR Studio to Spark AR Hub using the new upload functionality. Select the upload icon in the toolbar at the bottom left of the interface or select File > Upload.
  • Improved

    • Large projects open much faster.
    • Particle systems, 2D and 3D text, materials, lights and speakers show runtime value in the Inspector when bound to the Patch Editor or scripts.
    • Use blend shapes with normal mapping.
    • Multiple fixes to the display of the Inspector.

    Version v75 - Nov 11, 2019

    New

  • Split scripts across multiple files. This can be useful when you have large scripts or want to organize your files.
  • Improved

    • Two audio capabilities have new names: Triggered is now One-Shot and Ambient is now Looping.

    Version v74.1 - Oct 30, 2019

    New

  • Quickly find items in the Scene and Assets panels using the search functionality in the toolbar on the left of the interface. You can also use Command F or go to the main menu and select Edit > Find.
  • Click the question mark icon in the toolbar on the left of the interface to search documentation and get quick access to helpful tutorials and guides.
  • Manipulate an object to pivot around its own pivot point using Pivot or a central pivot point using Center.
  • Set input and output values for blocks using a slider.
  • Set Minimum or Maximum values for block inputs and outputs.
  • Improved

    • Projects with environment textures can now mirror without fail.
    • Crash reports automatically appear after crashes and include a streamlined way to send a crash log.
    • Texture extraction now works with face trackers.
    • Fixed a bug that caused issues logging into Sketchfab from the AR Library.
    • Fixed an issue with graphics on Windows machines.

    Version v73 - Oct 14, 2019

    New

  • Learn your way around in the Spark AR Studio Tour. The guided tour walks through essential parts of the interface and also shares the basics of building effects.
  • Add custom devices to the Simulator to easily test your effect. To add a custom device, select Preferences from the Spark AR Studio drop-down menu.
  • The maximum size of .arexport files — the files downloaded to your machine after exporting a project — is now 40MB.
  • Improved

  • Sample projects have animated images instead of static previews.
  • When you open a saved project, filters in the Viewport will be enabled or disabled in the same way they were when the project was last saved.
  • Assets imported from the AR Library no longer display as “scene” in the Assets panel. Instead, the name matches the original name of the asset.
  • Crash reports automatically appear after crashes and include a streamlined way to send a crash log.
  • SDK Changelog

    • Fixed environment texture rotation in Physically-Based Material.

    Version v72 - Sep 30, 2019

    New

  • Work on projects using multiple versions of Spark AR Studio. You’ll still be prompted to update to the latest version, but can disable these notifications. Find the different versions of Spark AR Studio you’ve downloaded in the main menu.
  • Create patches for the different emitter types (Line, Plane and Ring) in particle systems.
  • Access the target tracker in the Patch Editor.
  • Create patches to represent the Size, Scale, Rotation and Position properties of 2D objects. Patch functionalities that contradict 2D layout will be blocked.
  • Create object tap and producer patches for lights, vector objects, particle systems, text and rectangles using the Create button in the Inspector.
  • The animation playback controller properties have changed from Play, Pause and Stop to Play and Reset.
  • Improved

  • The device picker in the Simulator now shows device resolution.
  • When you open a saved project, objects in the Scene panel will be expanded or collapsed in the same way they were when you last saved.
  • Imported 3D objects are automatically scaled to fit the Viewport. If your objects were created with real-world scale, consider disabling this feature. You can do this by selecting Preferences from the Spark AR Studio drop-down menu and unchecking Automatically scale imported 3D models
  • SDK Changelog

    • Removed the empty Blocks module from the JS API.
    • Added support for remote images in the Native UI Picker.

    Version v71 - Sep 16, 2019

    New

  • Improved alignment for texture extraction. If the texture is applied to a face mesh, check the boxes next to Eyes and Mouth to ensure the texture aligns properly.
  • You can create patches for the Size property in 2D objects, allowing dynamic control of size in the Patch Editor.
  • Increment or decrement numerical values by pressing the up or down arrow keys in combination with Control or Option (Alt in Windows) keys.
  • SDK Changelog

    • Rotate environment lights and use them with Blocks.

    Version v70 - Sep 9, 2019

    New

  • Grid snapping is enabled by default for the Patch Editor. You can disable it in the View menu.
  • Rectangle and text models can be enabled and disabled for front and back cameras, preview and capture.
  • Use 3D shapes in particle systems. Choose from these predefined shapes.
  • Automatic compression for all files. Spark AR Studio will find the best type of compression for each texture, and for all devices, according to the image's contents.
  • Improved

    • Add minimum and maximum values to inputs and outputs on patch groups.

    Version v69 - Aug 19, 2019

    New

    • Collapse patches by hiding unconnected ports. This allows you to better arrange the layout of your patch graph.
    • Evaluate math expressions in numeric text fields in the Patch Editor. For example, you can type “(1 + 2) * 3” and it will evaluate to “9”.

    Version v68.1 - Aug 8, 2019

    New

  • You can now add multi-axis spray angle, 3D angular velocity and 3D rotation of particles to particle systems.
  • Playback controllers for audio can now pause and resume sounds.
  • You can now override an individual texture’s compression settings.
  • We now have a waveform visualizer on the audio preview inspector.
  • Improved

    • Fixed a crash that can occur when opening a document that contains segmentation.
    • We’ve added exported project sizes and Blocks support to the Asset Summary, and added an additional entry point to the Asset Summary in the Export window.
    • Play and loop inputs are now a boolean type for Playback Controllers. Check the play or loop checkbox to activate sounds.
    • We fixed a bug so callbacks that throw exceptions only occur once.

    Version v67 - Jul 22, 2019

    New

  • Blocks are now available to add to your scene/assets. They allow you to structure your project and save pieces of it that you can share or reuse. Combinations of scene objects, assets, patches, materials and textures are all supported by Blocks. Find out more about it in the documentation.
  • Simulator can now be docked alongside the main Viewport from the Simulator hamburger menu or the View menu.
  • SVG’s (Vector Objects and Vector Images) are now available to add to your scene/assets.
  • Code Autocomplete allows you to have Code Suggestions as well as Inline Documentation and Type Checking. Find out more in the documentation.
  • Imported animations will now let you create patches for nodes that are not targeted.
  • Created 2D manipulator for 2D objects: rotate, reposition and scale your 2D objects. Please note that migration is added for 2D objects. Please check your effects.
  • SDK Changelog

    • Expose the red, green, blue and alpha components of RGBA signal.
    • Transformations were introduced to planar objects, please check that your layout works as expected.

    Version v66 - Jul 22, 2019

    New

  • You can now use the Patch Editor to make changes to 3D Text.
  • You can also use the Patch Editor to make changes to 2D Text.
  • We’ve introduced 3D Text Texture Coordinate Modes.
  • Textures will automatically compress after import.
  • There’s now a Texture Sizes section in the Inspector.
  • You can manually compress textures through options in the Inspector.
  • You can also use global compression settings to compress textures. Go to Project; Edit Properties; Compression.
  • SDK Changelog

    • Deprecate pulse-typed Playback Controller Actions (play, loop and stop) in favor of new, boolean ones.
    • Added New Boolean Playback Controller Actions [patches, APIs] (play, loop and reset)
    • Introduce plane tracker to visual scripting.

    Version v65.1 - Jul 8, 2019

    Improved

    • Fixes a crash that can occur when inserting a plane tracker.

    SDK Changelog

    • Renamed 'CameraShare' scripting module to 'DeepLink'.

    Version v64 - Jun 24, 2019

    New

    • We've been making bug fixes and improvements based on your feedback.

    Version v63 - June 10, 2019

    New

    • We've been making bug fixes and improvements based on your feedback.
    • We've added a code example for the LiveStreaming Module.

    Version v62.1 - May 30, 2019

    New

    • We've been making bug fixes and improvements based on your feedback.

    Version v61 - May 16, 2019

    New

    Improved

    • We've been making bug fixes and improvements based on your feedback.

    Version v60 - April 29, 2019

    New

    • We've added a new sample effect to the welcome window. Learn more about using visual shaders in the Patch Editor - to create the effect of a beam of light shining across the face.

    • Sound Collection is back

    SDK Changelog

    • The setTexture method of the MaterialBase class now accepts enums instead of strings.

    Version v59 - April 15, 2019

    New

    SDK Changelog

    • The SdfTwist method of the Shaders Module has been renamed to sdfTwist to match all other method casing.

    Version v58 - April 2, 2019

    New

    Version v57 - Mar 18, 2019

    New

    Version v56 - March 1, 2019

    New

    • You can now add SVG images to your effect. Add the SVG asset to the assets panel, then use a scene object called a Vector Object to render them in the scene. You can manipulate, transform and control the visibility of vector objects (both manually and through Patch Editor). You can't import SVG assets that include strokes, opacity, gradients and patterns, clipping, masking, filter effects, linking, scripting, animation and fonts.
    • We've added a new sample project - Thumbs Up. Open the project by selecting Sample Projects when open Spark AR Studio. Find out more about building the effect yourself in our documentation.
    • We've added a new guide to our documentation. Learn more about using the face reference assets.

    Improved

    • More faithful import of physically based material using the specular/glossiness workflow.

    SDK Changelog

    • Expose alpha test threshold to scripting.
    • We've been working to achieve parity between the features available in the Patch Editor, and JavaScript. You can now create visual shaders using JavaScript.

    Version v55 - Feb 14, 2019

    New

    • Introduced a new environment light to assign a global environment texture to all physically-based materials
    • You can now manipulate, transform and control the visibility of 3D text in the Patch Editor.
    • We've added a new guide to our documentation - learn more about using the face tracker texture

    SDK Changelog

    • Ability to control instructions from JS

    Version v54 - Jan 25, 2019

    New

    • Signed Distance Fields are now available from the Patch Editor
    • We've deprecated flex and the legacy canvas. Use 2D layout - flexibility, pinning, alignment and filling properties - and the canvas instead. Enabled patch editor for such 3D Text properties as visibility and transformations (position / scale / rotation)

    Improved

    • Support for vertex colors in physically-based materials
    • Support for back material, line and letter spacing in 3D text

    SDK Changelog

    • Split face material of 3D text to front and back material
    • Introduce back material of 3D Text to the scripting
    • Expose properties of the physically-based material to scripting
    • Allows multiple point anchors to be used in the same effect

    Version v53 - Jan 4, 2019

    New

    • New face reference assets

    SDK Changelog

    • Line spacing property for 3D Text introduced to scripting
    • Letter spacing property for 3D Text introduced to scripting

    Version v52 - Dec 21, 2018

    Improved

    • We've improved the retouching shader. Skin smoothing has been improved and we've removed eye and teeth whitening.

    SDK Changelog

    • Introduce getBlendShapes methods that returns a promise of blend shapes array.

    Version v51 - Dec 7, 2018

    New

    • Spark AR Studio has a brand new welcome window
    • Image-based lighting for physically-based materials (with a selection of environment map presets)
    • Importing HDR files for image-based lighting
    • Add medium (MIP) and high (Trilinear) filtering options for textures

    Improved

    • Skin smoothing for retouching material

    SDK Changelog

    • Introduced pinLastValue method for ScalarValue, StringValue, BoolValue
    • Added count and name properties to BlendShape scripting

    Version v50 - Nov 19, 2018

    New

    • You can now use animation playback controllers to animate 3D objects, without needing to use the Patch Editor.
    • Full support of Metallic Roughness PBR materials from external assets.

    SDK Changelog

    • Introduced the 'pinLastValue' function, that creates a new signal which always returns the value that the original signal had immediately before 'pinLastValue' was called.
    • Exposed the emissive texture and associated transform of the standard and physically-based materials to scripting.

    Version v49 - Nov 2, 2018

    New

    • Effects will start from the beginning in the Viewport and Simulator, when the video is changed.
    • 3D Text feature is available now.

    Improved

    • Spark AR Studio will no longer crash when switching to camera input on macOS Mojave.
    • We fixed color encoding for compressed textures.

    Removed

    SDK Changelog

    • Introduced asin, acos, tan, atan functions.
    • Property getters which used to return Value types now return Signal types (e.g. BoolValue -> BoolSignal, ScalarValue -> ScalarSignal).
    • Transforms now have a 'toSignal' method, that converts them into a TransformSignals.
    • Introduced the FaceTracking2D module, that offers performance gains compared to tracking faces in 3D.

    Version v48 - Oct 19, 2018

    New

    • You can now choose whether objects are visible in either preview, capture or both. Use the check boxes in the Inspector, and test it using the Simulator.
    • We've introduced iris tracking. Connect the the new Eyeball patch to the Face Select patch, or use the “IrisTracking” JS module to track the eye rotation and iris position of faces in your scene.
    • Full support of glTF 2.0 materials and textures from imported files.

    Improved

    • AR Studio will no longer crash when opening the Preferences window in macOS Mojave.

    Patch Editor Improvements

    • New patches for face gestures: Kissing, Surprised and Happy.
    • The new Eyeball patch is available, allowing you to track the position and rotation of irises and eyes in your scene.

    Removed

    • Eye anchors in the face mesh. To track the position of eyes in your scene, use the “Left/Right Eyeball Center Position” output of the Eyeball patch.
    • Materials no longer have alpha test enabled by default to improve performance.

    SDK Changelog

    • Face blendshapes in legacy units are no longer supported. Previously-authored blendshapes must be scaled down to meters (scaled by a factor of 1/960) to continue to work in this version of AR Studio.
    • New methods for recognizing gestures in FaceGestures module.

    Version v47 - Oct 5, 2018

    New

    • It is now much easier to create effects that transform people's backgrounds using Segmentation. Simply select Scene→Camera→Segmentation→Segmentation Mask Texture, rather than using the insert menu.
    • When you're opening AR Studio for the first time, you'll be welcomed with a guided tour.
    • You can now change letter and line spacing for 2D Text.
    • You can persist effect data across AR sessions, using the new effect persistence feature.

    Improved

    • Significantly improved hand tracking quality on Mac OS platforms.

    SDK Changelog

    • lastValue property is deprecated
    • subscribeWithSnapshot, setTimeoutWithSnapshot and setIntervalWithSnapshot JS APIs are added to replace lastValue
    • worldTransform property for SceneObjectBase is added
    • Random module is added
    • spacing property for 2D text is added

    Version v46 - Sep 27, 2018

    New

    • FaceTracker now has 2D & 3D modes
    • You no longer need to click Run to see interactive parts of your scene - they'll play continuously. Use Pause and Restart in the tool bar to stop or reset your effect.

    Improved

    • Significantly improved hand tracking accuracy and performance

    Patch Editor Improvements

    • The Loop Animation patch has a new “Looped” output that is triggered when the animation completes and then starts again.

    SDK Changelog

    • 1200 HE face mesh is now used by default
    • 3D face tracking is now a separate capability
    • Legacy (lo-res) face mesh is deprecated

    Version v45 - September 7, 2018

    New

    • You can now use AR Library to add objects from Sketchfab's object library and free-to-use sound effects in your projects

    • You can now make a text node editable. Having that, you can trigger the keyboard input from scripting and make user input the value for the given text node.

    • You can now use Babel Support feature as a part of AR Studio and be sure that scripts works the same on both iOS and Android.

    Improved

    • New projects have speaker node in the scene by default
    • You can now adjust compression settings and preview textures in the Simulator.
    • Canvas now has a safe zone area so you can see where the camera interface lies and avoid this section
    • Rectangle now has a “fill parent” function which will resize to that of the parent

    Patch Editor Improvements

    • When using animation patches, the Option Picker patch no longer requires all inputs to be connected. You can leave some ports open.
    • We've changed all Progress ports to Numbers on all Transition & Animation patches. You can now see & change progress values directly on the patch ports, and connect them with numbers.

    Version v44 - Aug 24, 2018

    Improved

    • Properly focus on meshes, bones, skeletons by pressing F to reframe the camera to facilitate creation
    • Drastically improved asset import process, 4-10 times faster, and doesn't block the UI on import
    • Various minor bug fixes

    Patch Editor Improvements

    • Renamed Eye to Eyelid in patch editor

    Version v43- August 10, 2018

    Improved

    • We've enabled the hierarchy of 2D objects. This means you can nest 2D objects like Text and Rectangles as children of parent 2D objects.
    • In the Patch Editor, you can now use Visual Shaders to manipulate and apply complex materials to your effects.

    Patch Editor Improvements

    • Some errors now highlight the related patch.

    • Non-generic ports can no longer be connected to non-generic ports of a different type. For example, Face Tracker's Face output port can't be connected to Transition's Progress input port, because their port Types are different.

    • We've added Visual Feedback, which means port values should be updated during runtime.

    SDK Changelog

    • Firing start and reset at the same time will reset and start animation.

    What's New - Version 42 (July 27, 2018)

    New

    • We've added a new fill width and fill height feature for 2D objects. You can now make the size of 2D objects the same as, and responsive to, the size of the object's parent.
    • There's now import support for glTF 2.0 files.
    • We've introduce a new type of audio asset called Playback Controller. You can use it to play, loop and stop sounds.
    • We've introduced a new scene object called Speaker. Connect playback controllers to it to play audio clips.
    • We've introduced Smart Compression - simple controls for resolution and desired quality to make minimizing texture file size easier. Use Smart Compression on a global or per-texture level to automatically lower the quality of simple textures while preserving detail in more complex textures.

    Improved

    • When deleting multiple external assets, only one confirmation popup will now be shown.

    Patch Editor Improvements

    • Imported animations are now compatible with Animation, Loop Animation and Progress patches.
    • Switching from one imported animation to another does not stack animations.
    • Patch Editor errors related to the misconfiguration of a patch now highlights the patch to give more context to the user.
    • Patches that represent assets are orange-colored.

    Removed

    • Audio Source scene node - use Speaker from now on.

    SDK Changelog

    • Improved patches for imported animations: switching from one animation to another doesn't stack animations.
    • Added capability to be able to change volume of audio sources, “AudioSourceVolume API”

    Version v41 - July 13, 2018

    New

    • The simulator now shows instructions when script is running.
    • Introduced texture-level color encoding settings. In the image texture inspector, one can now mark the selected texture as using image data with sRGB or linear color encoding.
    • Introduced material-level color encoding settings. In the Inspector, you can now mark the selected material as producing colors with sRGB or linear color encoding.
    • You can now reveal the Asset Summary from the Inspector panel.
    • You can now reveal Global Compression Settings from the Inspector panel.
    • You can now search Key Binding preferences.
    • We've introduced a new physically-based material. This allows artists to create materials following the metallic/roughness PBR workflow which simulate more realistically the interaction between materials and lights.

    Improved

    • Effects now restart after updating a newly added script.
    • Fixed out of focus state of the Center and Global toolbar buttons.
    • We now validate the token input in the instruction patch when script is running.
    • Improved UX of External Textures.

    SDK Changelog

    • New setInterval and clearInterval APIs introduced to the TimeModule.
    • Enable reversing and resetting at the same time for animation.

    Version v40 - Jun 29, 2018

    New

    • The simulator window now shows the effect on textures of the target compression method of the selected device, to make it easier to iterate on compression settings without having test devices to hand. You can only use this feature when compression of imported textures has finished.
    • The new Devices preference pane can be used to add custom devices to the set of devices available in the simulator. Devices can be specified by their screen resolution and texture compression method.
    • You can now add instructions to your project, to give people hints when they're using your effect in the camera.

    Improved

    • Import of duplicated textures is now supported. Identical files will be de-duplicated as part of the export flow, and the sizes in the export pane and the asset summary will reflect this.
    • The Asset Summary now contains a root Project node that indicates the full size of your packaged project. The sizes here are the sizes of the full export and the same as those given in the export panel. There's also an Other entry that contains the size of the data model, scripts, and any other files that contribute to your export sizes that aren't otherwise included in the asset summary. To fill-in the table with these sizes, you might need to to press the Compress All button.
    • Minor Asset Summary improvements:
      • The Asset Summary can be launched from the Project menu, rather than the View menu.
      • The ordering of download and unpacked (on-device) sizes has been swapped, to make them consistent with the Inspector.
      • The Compress All button is now disabled when the table is fully-populated.
    • An emission texture can now be specified for standard materials. It will be modulated with the existing emission color for rendering.
    • An alpha cutoff can now be specified for materials that support advanced options. This allows transparent areas with an alpha lower than the specified threshold (which was previously forced to be zero) to be masked out from rendering.
    • We've fixed alpha operations (blending, alpha test) that were incorrectly taking into account specular values for lit materials.

    Patch Editor Improvements

    • Hand Tracking is now supported in the patch editor.

    SDK Changelog

    • Introduces signal.delayBy({milliseconds: number}) to obtain a delayed version of a signal.

    What's New - Version 39 (June 18, 2018)

    • The Hand Tracking capability is released to public.
    • Instead of using Flex and Anchor to position 2D objects, you can now use a combination of Alignment and Pinning. We've also added Flexibility, which scales objects objects proportionately to their parent.

    Patch Editor improvements

    • Added support for Color type in If Then Else and Option Picker patches.
    • Added Option Sender patch.
    • Changed default type of Transition patch to Point 3D.

    SDK Changelog

    • When mapped to a full-screen canvas, the extracted camera texture aligns correctly with the camera frame.
    • The layout algorithm has been refined, please check that your layout works as expected.
    • Introduce ReactiveHandModule: a module for hand tracking.
    • Expose position, scale and rotation properties as signals from object's transform. Now it's possible to bind object's properties to each other: a.transform.x = b.transform.x.add(5)

    What's New - Version 38 (June 1, 2018)

    Improved

    • When you've exported an effect, there will now be a link to the effect in the Publishing Hub.

    Patch Editor improvements

    New

    • Patches from the Patch Editor are now accessible from JS scripting.
    • The Patch Library will now filter compatible patches when double clicking on ports from a graph in Patch Editor. You can also drag from a port to an empty area.

    Improved

    • The color picker control will be dimmed when the port is connected.

    SDK Changelog

    New

    • A parameter for skin smoothing is available for the retouching material via scripting.
    • Added read-only Face.isTracked() to expose whether a face is tracked in the current frame.

    Improved

    • When a progress with start == end is instantiated, an exception will now be thrown.

    Join the Spark AR Creator's community

    Find inspiration, see examples, get support, and share your work with a network of creators.

    Join Community

    Join the Spark AR Creator's community

    Find inspiration, see examples, get support, and share your work with a network of creators.

    Join Community

    Frequently asked questions

    Have a specific question? Maybe it's been answered.


    Read FAQs
    Was this document helpful?